I suggest you ...

Update ElasticSearch version to latest

ElasticSearch package is outdated and needs to be updated to be compatible with my current applications.

73 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Cormac shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

41 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    the breaking moment for me not going for cloudways hosting was es version. 2.4x is old. soon the support will end as well. with numerous upgrades and advantages 5.x is the way couldways should go.

  • Ian commented  ·   ·  Flag as inappropriate

    I also need this. I had to set up a bare VULTR VPS in the same datacenter as my Cloudways system and install Elasticsearch on that instead. IT works just fine, but it'd be nice to keep everything in one place.

  • Ian commented  ·   ·  Flag as inappropriate

    I needed this as well and ended up getting a separate VULTR server in the same datacenter as my Cloudways VULTR server to run ES 5.4 on. I wish I didn't have to do it but there wasn't any other option. ES needs lots of memory to run well anyway so a separate server isn't such a bad idea.

  • RyanRobi commented  ·   ·  Flag as inappropriate

    ActiveCollab says that search features require ElasticSearch 1.7.4 and Java. Does anyone have ActiveCollab search running on a Cloudways server? With the requirement for Java I'm not sure how it could be done.

  • Kristen commented  ·   ·  Flag as inappropriate

    We need ElasticSearch 5 available in the stack to support Magento 2 ElasticSearch & the Mirasvit extension.

  • AA commented  ·   ·  Flag as inappropriate

    Currently, we can only install elastic search 2.4.
    But a lot of plugins now require min. version 5 and above.
    So please add option to go for V5 or above for ES.
    Thanks

  • Kristin commented  ·   ·  Flag as inappropriate

    I agree!! Was trying to implement a WooCommerce search/filter plugin which requires v5

  • Anonymous commented  ·   ·  Flag as inappropriate

    Currently the only versions of Elasticsearch are very old, the current version is V5.x and you are only offering 2.x There are numerous improvements in the latest version that would be helpful

  • Mosies Garcia commented  ·   ·  Flag as inappropriate

    Perhaps, we should have the option to chosse ElasticSearch version. Latest 5.X version has the best performance and uses less resources.

  • Michael commented  ·   ·  Flag as inappropriate

    Besides aC I think most apps have moved to ES 2.x, this seems inevitable but in the meantime lots of us are hamstrung

  • Brendyn Montgomery commented  ·   ·  Flag as inappropriate

    We'd need the ability to choose the version as Active Collab requires 1.7.x and won't work on 2.x at the moment and without that our project management tool is down the toilet :)

Feedback and Knowledge Base