I suggest you ...

Server SMTP configuration is not working properly.

Currently if you have already configured the SMTP on a server Cloudways seems to remember your previous credentials and tries to enter them again. I've just spent half an hour trying to set up SendGrid on the Server SMTP. Everytime I selected SendGrid or Mailgun etc it would automatically fill in the wrong credentials and process them. Finally I was able to remove them and get the proper credentials in. But it took a lot of my time and I'm not happy that I wasted so much time.

This needs to be fixed.

Thanks,
John Anderson.

1 vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base