I suggest you ...

Update Drupal Installation PHP version Restriction

Currently Drupal 8 installation only runs when server PHP is set to 7.2.

From a discussion with Cloudways support, I know that it's because the "recommended" PHP version for Drupal 8.5+ is PHP 7.2.

However, it only recommended PHP 7.2, it doesn't says Drupal 8.5+ is not compatible with PHP 7.1 or older.

And Cloudways stopped me from installing new Drupal 8 application when my server is running PHP 7.1.

Please do take note that Drupal Core itself is compatible with PHP 7.2, but not all the contributed modules are compatible.

What I have to went through now is I have to change my server PHP version to PHP 7.2, install Drupal 8 application, and switch back to PHP 7.1.

And my other applications (some are production sites) in the same server is throwing errors due to the modules installed is not compatible with PHP 7.1.

It's an actual scenario where the PHP 7.2 restriction is causing user troubles.

I do hope that you could update the restriction based on "supported" PHP version instead of "recommended" PHP version, while the user will determine what version of PHP should be run in a server.

Thanks.

1 vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

ironmath3w shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base